
<!DOCTYPE html>

<html lang="en" xmlns:og="http://opengraphprotocol.org/schema/">

<head>

<!-- Begin Pico -->
<script>(function(p,i,c,o){var n=new Event("pico-init");i[p]=i[p]||function(){(i[p].queue=i[p].queue||[]).push(arguments)},i.document.addEventListener("pico-init",function(e){var t=i.Pico.getInstance(e,{publisherId:o,picoInit:n},i);t.handleQueueItems(i[p].queue),i[p]=function(){return t.handleQueueItems([arguments])}},!1);var e=i.document.createElement("script"),t=i.document.getElementsByTagName("script")[0];e.async=1,e.src=c,e.onload=function(e){return i.Pico.getInstance(e,{publisherId:o,picoInit:n},i)},t.parentNode.insertBefore(e,t)})("pico",window,"https://widget.pico.tools/wrapper.min.js","9436a032-15d6-4bd7-b666-ce35eb7905d1");</script>
<!-- End Pico -->

<!-- Quantcast Choice. Consent Manager Tag -->
  <script type="text/javascript" async=true>
    var __cmp = (function () {
      return typeof (__cmp) == "function" ? __cmp : function (c) {
        var b = arguments;
        if (!b.length) {
          return __cmp.a;
        }
        else if (c == '__cmp')
          return false;
        else {
          if (typeof __cmp.a === 'undefined') {
            __cmp.a = [];
          }
          __cmp.a.push([].slice.apply(b));
        }
      }
    })();
    var elem = document.createElement('script');
    elem.src = "https://quantcast.mgr.consensu.org/cmp.js";
    elem.async = true;
    elem.type = "text/javascript";
    var scpt = document.getElementsByTagName('script')[0];
    scpt.parentNode.insertBefore(elem, scpt);

    window.__cmp('init', {
  		'Language': 'en',
		'Initial Screen Reject Button Text': 'I do not accept',
		'Initial Screen Accept Button Text': 'I accept',
		'Purpose Screen Header Title Text': 'Privacy settings',
		'Purpose Screen Body Text': 'You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.',
		'Vendor Screen Body Text': 'You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.',
		'Vendor Screen Accept All Button Text': 'Accept all',
		'Vendor Screen Reject All Button Text': 'Reject all',
		'Initial Screen Body Text': 'We and our partners use technology such as cookies on our site to personalise content and ads, provide social media features, and analyse our traffic. Click below to consent to the use of this technology across the web. You can change your mind and change your consent choices at anytime by returning to this site.',
		'Initial Screen Body Text Option': 1,
		'Publisher Name': 'Jackson Free Press',
		'Publisher Logo': 'http://www.bestofjackson.com/wp-content/uploads/2016/01/JFP_NEW_FLAG_stacked_FACEBOOK.jpg',
		'Post Consent Page': 'http://www.google.com/',
		'Consent Scope': 'service',
    });
  </script>
  <!-- End Quantcast Choice. Consent Manager Tag -->
    <style>
    </style>


<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');

fbq('init', '533049636824431');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=533049636824431&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

<!-- Mobile-opt-in stuff here -->
<script type="text/javascript">
	var STATIC_MEDIA_URL = 'https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/';
</script>

  <script type="text/javascript" src="https://google.com/maps/api/js?sensor=true"></script>
  <script type="text/javascript" src="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/min.js"></script>
  
  <script type="text/javascript" src="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/javascript/thirdparty/wmd.js"></script>
  <script type="text/javascript" src="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/javascript/onload.js"></script>

<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="google-site-verification" content="IWXFYfZIttPjrHp6PHTaRrN9WFAh-rc2CZiQeV0pHiU" />

  <title>Jackson Protest to Honor George Floyd, Call for End to Systemic Racism | Jackson Free Press | Jackson, MS</title>
  
  
  
  <meta name="description" content="Calvert White, vice president of Alcorn State University’s chapter of the NAACP, says George Floyd is a “martyr,” killed by an oppressive power complex that affects everyone in the country.">
  <meta property="og:title" content="Jackson Protest to Honor George Floyd, Call for End to Systemic Racism">
  <meta property="og:type" content="article">
  <meta property="og:url" content="http://www.jacksonfreepress.com/news/2020/jun/03/jackson-protest-honor-george-floyd-call-end-system/">
  <meta name="twitter:card" content="summary_large_image">
  <meta name="twitter:site" content="@jxnfreepress">
  <meta name="twitter:title" content="Jackson Protest to Honor George Floyd, Call for End to Systemic Racism">
  <meta name="twitter:description" content="Calvert White, vice president of Alcorn State University’s chapter of the NAACP, says George Floyd is a “martyr,” killed by an oppressive power complex that affects everyone in the country. ">
<meta name="twitter:image" content="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2020/06/03/Maise-Brown_courtesy_web.jpg">




  <link rel="shortcut icon" type="image/x-icon" href="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/jacksonfreepress/2.3.0/images/jfp_favicon.ico">
  <link rel="stylesheet" href="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/min.css" type="text/css" media="screen, print">
  <link rel="stylesheet" href="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/jacksonfreepress/2.3.0/stylesheets/print.css" type="text/css" media="print">
  
  <!--[if IE 6]><link rel="stylesheet" href="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/stylesheets/ie6.css" type="text/css" media="screen"><![endif]-->
  <!--[if IE 7]><link rel="stylesheet" href="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/stylesheets/ie7.css" type="text/css" media="screen"><![endif]-->  

  
    <link rel="stylesheet" href="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/jacksonfreepress/2.3.0/jfp-less/mod.css" type="text/css" media="screen">


  <script type="text/javascript">
    var STATIC_MEDIA_URL = 'https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/';
  </script>
  

<!-- GOOGLE AD SCRIPT -->

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1024782/Top_Banner', [728, 90], 'div-gpt-ad-1550259565865-0').addService(googletag.pubads());
    googletag.defineSlot('/1024782/Top_300_250', [300, 250], 'div-gpt-ad-1550259823887-0').addService(googletag.pubads());
    googletag.defineSlot('/1024782/Top_Skyscraper', [160, 600], 'div-gpt-ad-1550262894638-0').addService(googletag.pubads());
    googletag.defineSlot('/1024782/Second_Skyscraper', [160, 600], 'div-gpt-ad-1550263161137-0').addService(googletag.pubads());
    googletag.defineSlot('/1024782/Second_300_250', [300, 250], 'div-gpt-ad-1550263248411-0').addService(googletag.pubads());
    googletag.enableServices();
  });
</script>

<!-- /GOOGLE AD SCRIPT -->

<!-- Typekit -->
    <script type="text/javascript" src="https://use.typekit.com/dzz7rzp.js"></script>
    <script type="text/javascript">try{Typekit.load();}catch(e){}</script>
<!-- /.Typekit-->


  


  <script type="text/javascript">
    
    jQuery(document).ready(function() {
      jQuery("#legacy-comments h1").html('Previous Comments <span class="lone-link">show</span>');
      jQuery("#legacy-comments h1").after('<p class="whatthis highlight-type">What\'s this?</p>');
      jQuery("#legacy-comments h1").css("border-bottom", "0");
      jQuery(".legacy-comment").hide();


      jQuery('#legacy-comments p.whatthis').click(function() {
        alert('In 2012 the Jackson Free Press moved to a new website. The system did not support old comments becoming new comments, so we placed them here. In many cases, these comments are as meaningful as the story that inspired them.');
      });

      /* Reformat legacy-comment-dates */
      jQuery('span.legacy-comment-date').each(function() {
        var html = jQuery(this).html().substring(0,10);
        var d = jQuery.datepicker.parseDate('yy-mm-dd', html);
        var s = jQuery.datepicker.formatDate("M d yy", d);
        jQuery(this).html(s);
      });

      /* toggle the componenet with class msg_body */
      jQuery("#legacy-comments h1").click(function() {
        jQuery(".legacy-comment").slideToggle(500);
        if (jQuery("#legacy-comments h1 span.lone-link").html() == 'show') {
          jQuery(this).html('Previous Comments <span class="lone-link">hide</span>');
        } else {
          jQuery(this).html('Previous Comments <span class="lone-link">show</span>');
        };
      });

    });

    $(document).ready(function() {

      var h3 = $("h3:contains('Previous Comments')");
      /* Setup classes */
      h3.nextAll('dl').addClass('previous-comment');
      h3.nextAll('hr').remove();

      /* Add Elements */
      h3.css('margin-top','20px');
      h3.css('cursor','pointer');
      h3.append('<span class="previous-comment-toggle lone-link">show</span>');
      h3.after('<span class="whatthis">What\'s this?</span>');
      $(".previous-comment").hide();

      /* Remove and rearrange elements */
      $(".previous-comment").each(function(){
        $(this).children('dt').remove();
        $(this).children('dd').first().remove();
        var html = $(this).children('dd').last().html().substring(0,10);
        var d = $.datepicker.parseDate('yy-mm-dd', html);
        var s = $.datepicker.formatDate("M d yy", d);
        $(this).children('dd').last().html(s);
      });

      /* Add Effects */
      $('span.whatthis').click(function() {
        alert('In 2012 the Jackson Free Press moved to a new website. The system did not support old comments becoming new comments, so we placed them here. In many cases, these comments are as meaningful as the story that inspired them.');
      });

      /* toggle the componenet with class msg_body */
      h3.click(function() {
        $(".previous-comment").slideToggle(500);
        if ($(".previous-comment-toggle.lone-link").html() == 'show') {
          $(".previous-comment-toggle.lone-link").html('hide');
        } else {
          $(".previous-comment-toggle.lone-link").html('show');
        };
      });


    });



  </script>


  
  <link type="application/rss+xml" rel="alternate" href="/rss/comments/objects/147/43491/">

  
  <meta name="viewport" content="width=1020">
  

<!-- MailMunch for Jackson Free Press -->
<!-- Paste this code right before the </head> tag on every page of your site. -->
<script src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-mailmunch-site-id="293557" async="async"></script>

<style>
.converted-anchor {display:none !important;}
</style>

</head>

<body class="news story_detail revision" id="story_43491">

<div id="page">

  
  <div id="toolbar">
    <div class="wrapper">
      
        
  <ul>
    <li class="news"><a href="/">JFP</a></li>
    <li class="news"><a href="http://www.boomjackson.com">Boom</a></li>
    <li class="news"><a href="http://www.jfpmenus.com">JFPMenus</a></li>
    <li class="news"><a href="http://www.bestofjackson.com/">BestofJackson</a></li>
    <li class="news"><a href="/news/newsletter/">JFPDaily</a></li>
    <li class="news"><a href="/advertise/">Advertise</a></li>
    <li class="news"><a href="/contact/">Contact</a></li>
	<li class="news"><a href="/awards/">Awards</a></li>
  </ul>

        
<ul class="user">
    <li class="search">
        <form action="/search/" method="get" class="search_form" autocomplete="off">
            <p class="query"><input type="text" name="q" placeholder="search" value=""></p>
        </form>
    </li>
    
        <li><a href="/accounts/login/?next=/news/2020/jun/03/jackson-protest-honor-george-floyd-call-end-system/">Sign in</a></li>
    
</ul>

      
    </div>
  </div>
  

  
  <div id="header">
    <div class="wrapper">
      
<div class="branding">
        <h1><a href="/">Jackson Free Press<!-- <span class="jfp">JFP</span><span class="ms">.ms</span> --></a></h1>
        <p><a href="#body">Jump to content</a></p>
</div>

<div class="ad">

<!-- /1024782/Top_Banner -->
<div id='div-gpt-ad-1550259565865-0' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1550259565865-0'); });
</script>
</div>

</div>

</div>

    </div>
  </div>
  

  
  <div id="nav">
    <div class="wrapper">
      
    <ul class="upper">
        <li class="l1"><a href="/news/all">News</a>
            <ul class="u1">
                <li class="l1"><a href="/news/all/">Home</a></li>
                <li class="l1"><a href="/news/justice/">Justice</a></li>
                <li class="l2"><a href="/news/education/">Education</a></li>
                <li class="l3"><a href="/news/politics/">Politics</a></li>
                <li class="l4"><a href="/news/business/">Business</a></li>
                <li class="l5"><a href="/news/people/">People</a></li>
                <li class="l6"><a href="/news/media/">Media</a></li>
                <li class="l7"><a href="http://blogs.jacksonfreepress.com/">Jackblog</a></li>
                <li class="l6"><a href="/news/covers/">Covers</a></li>
            </ul>
        </li>
        <li class="l2"><a href="/news/opinion">Opinion</a>
            <ul class="u2">
                <li class="l1"><a href="/news/opinion">Home</a></li>
                <li class="l2"><a href="/weblogs/">Weblogs</a></li>
            </ul>
        </li>
        <li class="l3"><a href="/news/arts/">Arts</a>
            <ul class="u3">
                <li class="l1"><a href="/news/arts/">Home</a></li>
                <li class="l1"><a href="/news/film/">Film</a></li>
                <li class="l2"><a href="/news/books/">Books</a></li>
                <li class="l3"><a href="/news/art/">Art</a></li>
                <li class="l4"><a href="/news/theater/">Theater</a></li>
                <li class="l5"><a href="/news/dance/">Dance</a></li>
            </ul>
        </li>
        
        <li class="l4 upper"><a href="/news/music/">Music</a>
            <ul class="u4">
                <li class="l1"><a href="/news/music/">Home</a></li>
                <li class="l2"><a href="/news/music/listings/">Music Listings</a></li>
		<li class="l4"><a href="/places/music-venue/">Music Venues</a></li>
                <li class="l5"><a href="/bands/">Local Bands</a></li>
                <li class="l6"><a href="/weblogs/music/">Music Blog</a></li>
            </ul>
        </li>

        <li class="l5 upper"><a href="/calendar/">Calendar</a>
            <ul class="u5">
                <li class="l1"><a href="/calendar/">Happening Today</a></li>
                <li class="l3"><a href="/events/exhibits/">Ongoing Exhibits</a></li>
                <li class="l4"><a href="/galleries/">Galleries</a></li>
                <li class="l5"><a href="/events/ongoing/">Other Ongoing Events</a></li>
            </ul>
        </li>

        
        <li class="l6"><a href="/news/lifestyle/">Life+Style</a>
            <ul class="u6">
                <li class="l1"><a href="/news/lifestyle/">Home</a></li>
                <li class="l2"><a href="/news/bodysoul/">Body+Soul</a></li>
                <li class="l3"><a href="/news/good/">GOOD Ideas</a></li>
                <li class="l2"><a href="/news/faith/">Faith</a></li>
                <li class="l4"><a href="/news/home-garden/">Home & Garden</a></li>
                <li class="l5"><a href="/news/hitched/">Hitched</a></li>
                <li class="l6"><a href="/news/flystyle/">Fly! Style</a></li>
                <li class="l5"><a href="/news/girl-about-town/">Girl About Town</a></li>
                <li class="l4"><a href="/news/running-recreation/">Running & Recreation</a></li>
                <li class="l3"><a href="/news/travel/">Travel</a></li>
                
            </ul>
        </li>
        <li class="l7"><a href="/news/food&drink/">Food+Drink</a>
            <ul class="u7">
                <li class="l1"><a href="/news/food&drink/">Home</a></li>
                <li class="l2"><a href="/restaurants/">Restaurants</a></li>
                <li class="l3"><a href="/weblogs/food/">Food Blog</a></li>
            </ul>
        </li>
        <li class="l8"><a href="/news/sports/">Sports</a>
            <ul class="u8">
                <li class="l1"><a href="/news/sports/">Home</a></li>
                <li class="l2"><a href="/sports/the_slate">Slate - Schedule</a></li>
                <li class="l3"><a href="/categories/news/bryans-rant">Bryan's Rant</a></li>
                <li class="l4"><a href="/weblogs/sports/">Sports Blog</a></li>
            </ul>
        </li>
        
    </ul>


    </div>
  </div>

  

  



  
    
    
    

    
  

  <div class="breadcrumbs">
    
  </div>

  
  <div id="body">
    <div class="wrapper">
      
        
        
        

        
          <div class="content_title">
            
  <div id="target-story_headline_template">
  
    <h2 class="header">Jackson Protest to Honor George Floyd, Call for End to Systemic Racism</h2>
    
      
    
  
  </div>

          </div>
        

        
        

        
          
          <div class="content">
            

            
              
                 
              
            

              
  
    
    <div class="story_lead_photo">
      <div class="photo">
        
        <a href="/photos/2020/jun/03/36969/"><img src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2020/06/03/Maise-Brown_courtesy_web_t670.jpg?b3f6a5d7692ccc373d56e40cf708e3fa67d9af9d" alt="Maisie Brown says a peaceful protest at the Governor’s Mansion at 3 p.m. on June 6 will call for an end to systemic racism against the black community in America. “We’re not enraged because this is the first time we’ve seen it. We’re enraged because we’ve seen it too many times before,” the protest co-organizer said. Photo courtesy Maisie Brown"></a>
        
      </div>
      <p class="caption">
        Maisie Brown says a peaceful protest at the Governor’s Mansion at 3 p.m. on June 6 will call for an end to systemic racism against the black community in America. “We’re not enraged because this is the first time we’ve seen it. We’re enraged because we’ve seen it too many times before,” the protest co-organizer said. Photo courtesy Maisie Brown
        
      </p>
    </div>
    
  

  <div class="content_info">
    

<span class="byline">
    
        
            
                
                    By <a href="/staff/nick-judin/">Nick Judin</a>
                
            
        
    

    
</span>

      <span class="datetime">
        <a href="/news/2020/jun/03/jackson-protest-honor-george-floyd-call-end-system/">
          Wednesday, June 3, 2020 1:04 p.m. CDT
        </a>
      </span>

    
    

<div class="vote_box">
	<form action="/accounts/login/?next=/news/2020/jun/03/jackson-protest-honor-george-floyd-call-end-system/" method="post" class="vote_form single is_anonymous"><input type='hidden' name='csrfmiddlewaretoken' value='9Ods1s3JbFu4qab5ZriEhSq96AF4WplZ' />
	  <button class="upvote " type="submit" name="value" value="1">Upvote</button>
	  
	  <span class="vote_count">0</span>
	  <input type="hidden" name="content_type" value="147">
	  <input type="hidden" name="object_id" value="43491">
	</form>
</div>

  </div>

  
  <div class="story_body" id="target-story_body_template">
    <p id="h175572-p1" class="permalinkable">Calvert White, vice president of Alcorn State University’s chapter of the NAACP, says George Floyd is a “martyr,” killed by an oppressive power complex that affects everyone in the country. </p>

<p id="h175572-p2" class="permalinkable">A video captured Minneapolis, Minn., police officer Derek Chauvin using his knee to pin Floyd’s neck to the street for nearly nine minutes, sparking nationwide protest over systemic racism and brutality inside law enforcement that protesters argue is destructive to their humanity and civil rights. Floyd committed no act of violence before his death at the knee of a police officer with three others guarding the action. Convenience-store employees had called the police, believing Floyd paid for cigarettes with a $20 counterfeit bill, but with no evidence that he was aware that it was fake. </p>




<div class="inline inline_photo inline-right ">
  <p class="thumbnail">
    <a href="/photos/2020/jun/03/36970/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2020/06/03/MS-Poor-Peoples-Campaign_Call-for-Moral-Revival-Flier_cred-MS-Poor-Peoples-Campaign_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Photo courtesy Mississippi Poor People&#39;s Campaign</p>
    
  </div>
</div>


<p id="h175572-p3" class="permalinkable">The Hill <a href="https://thehill.com/homenews/state-watch/500566-owner-of-store-that-called-cops-on-george-floyd-says-theyll-stop-calling">reported</a> that the store’s owner later said he would no longer report fake bills to the police, due to the violent reaction to Floyd. “Police are supposed to protect and serve their communities; instead, what we’ve seen over and over again is the police abusing their power and violating the people’s trust. We realize now that escalating situations to the police almost always does more harm than good, even for something as harmless as a fake bill,” Mahmoud Abumayyaleh, the owner of Cup Foods, <a href="https://www.facebook.com/mabumayyaleh/posts/10222481025630705">wrote on Facebook Sunday</a>.</p>

<p id="h175572-p4" class="permalinkable">Calvert White cautions that the nationwide protests represent far more than outrage over Floyd’s killing alone, however. “George Floyd’s death is symbolic of police brutality all over the nation. It’s very clear that the justice system is inherently flawed,” White told the Jackson Free Press.</p>

<p id="h175572-p5" class="permalinkable">White, along with co-organizer Maisie Brown, are organizing a peaceful protest at the Governor’s Mansion in Jackson at 3 p.m. Saturday, June 6, against <a href="https://www.raceforward.org/videos/systemic-racism">police brutality and the systemic racism</a> that bolsters and protects it. </p>

<p id="h175572-p6" class="permalinkable"><strong>‘Floyd Is the Straw that Broke the Camel’s Back’</strong></p>

<p id="h175572-p7" class="permalinkable">Maisie Brown, the 18-year-old youth program director at the Institute for Democratic Education in America and a recent Murrah High School graduate, considers the Minneapolis death a flashpoint. “Floyd is the straw that broke the camel’s back. Back in the ‘90s, our parents had <a href="https://www.npr.org/2017/04/26/524744989/when-la-erupted-in-anger-a-look-back-at-the-rodney-king-riots">Rodney King</a>. We’re not enraged because this is the first time we’ve seen it. We’re enraged because we’ve seen it too many times before.”</p>

<p id="h175572-p8" class="permalinkable">The organizers of the Jackson protest uniformly stress that the action will be peaceful, including voices from black students, activists, community leaders and artists. </p>

<p id="h175572-p9" class="permalinkable">“We want to march past the old Capitol, up to the Capitol, and back to the Governor’s Mansion, and let them know—not just Tate Reeves, but any white, racist politician in the state and the nation—know that Mississippi is not just the ones you care about: there are a lot of people here who are eager for change,” Brown said of the Saturday protest. She is also an <a href="https://www.jacksonfreepress.com/news/2018/dec/03/opinion-young-people-are-fired-mississippi-bring-c/">occasional columnist for the Jackson Free Press</a>. </p>

<p id="h175572-p10" class="permalinkable">The Saturday event will follow Friday’s gathering organized by Mississippi’s Poor People’s Campaign, which will take place outside Attorney General Lynn Fitch’s office at the Walter Sillers Building on June 5 at noon.</p>

<p id="h175572-p11" class="permalinkable">That event will protest Fitch’s move last week to dismiss the manslaughter case against Canyon Boykin, the white ex-police officer from Columbus who shot and killed Ricky Ball during a traffic stop in 2015. Fitch dismissed the case against Boykin with prejudice, meaning the state may not bring the case back up on the same grounds if future evidence emerges.</p>

<p id="h175572-p12" class="permalinkable">Danyelle Holmes, national organizer with Repairers of the Breach and the Poor People’s Campaign, says far too many questions surround Boykin’s shooting of Ball for a permanent dismissal. She ties the action back to the national unrest over racism in the justice system.</p>

<p id="h175572-p13" class="permalinkable">“We have a flawed system, not only on the national level, with our president, but on the local level, with our state government. … African Americans can't rely on the system for justice. We have not been able to rely on the system for many years,” Holmes said.</p>

<p id="h175572-p14" class="permalinkable">The Mississippi Poor People’s Campaign is sending an open letter to Fitch in protest of the decision in the Ricky Ball case. “Historically, black victims have not received the same treatment in the judicial process in cases similar to this one. Mr. Ball is not the first victim of a police shooting that has gone unprosecuted. In Mississippi, no police officer has ever been convicted of killing a black person, though there have been multiple police-involved shootings,” the letter reads.</p>

<p id="h175572-p15" class="permalinkable"><strong>‘The Work Has to Start Within White People’</strong></p>

<p id="h175572-p16" class="permalinkable">Across the nation, stunning outpourings of unrest, anger, and solidarity have fueled a week of protests and riots in virtually every major U.S. city. In response to that civil unrest, political leaders and media figures have attempted to set the parameters for “legitimate” protest, an act Maisie Brown finds offensive and unhelpful.</p>




<div class="inline inline_photo inline-right ">
  <p class="thumbnail">
    <a href="/photos/2020/jun/03/36971/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2020/06/03/Protest-at-the-Governors-Mansion-Flier_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      
    
  </div>
</div>


<p id="h175572-p17" class="permalinkable">“I don’t think it is the role of the oppressor to tell the oppressed what’s an appropriate response,” Brown said. The march on Saturday is in every sense a peaceful protest, but Brown has no interest in condemning riots as illegitimate. </p>

<p id="h175572-p18" class="permalinkable">“I’m in no way angry with people who chose a different route,” she said, adding, “As Martin Luther King Jr. said, riots are the language of the unheard.”</p>

<p id="h175572-p19" class="permalinkable">The organizers said white allies, too, have to understand which forms of support are constructive, and which are not. </p>

<p id="h175572-p20" class="permalinkable">“I want white people to support this movement,” Brown said. But, she added, ”white people have to mobilize themselves. We can’t fix what wasn’t made for us. We can’t fix what we didn’t break. The best thing you can do to support me is to talk to your people. … The work has to start within white people.”</p>

<p id="h175572-p21" class="permalinkable">Calvert White wants a broad coalition, but asked that participants let them lead. “Educate yourselves, fight with us … understand that we have to shout to be heard,” he advised.</p>

<p id="h175572-p22" class="permalinkable"><strong>Gov. Tate Reeves on ‘Anarchists and Agitators’</strong></p>

<p id="h175572-p23" class="permalinkable">U.S. Attorneys Mike Hurst and Chad Lamar issued a joint press release this morning addressing Floyd’s death and the ensuing protests. “What happened to George Floyd in Minnesota was heartbreaking and a travesty, but I am proud of the way Mississippians have responded by exercising their First Amendment rights peacefully,” Hurst said in the release.</p>

<p id="h175572-p24" class="permalinkable">But the support for peaceful protests was leavened with a warning. “Law and order will be maintained coequally with the lawful exercise of individual liberties. We took an oath to support and defend the American people and the Constitution, and we will continue to do just that,” Hurst said in the statement.</p>

<p id="h175572-p25" class="permalinkable">Gov. Tate Reeves, responding to the nationwide protests now coming to Mississippi, swore that “we will never suppress speech and protest in Mississippi,” but also <a href="https://www.jacksonfreepress.com/news/2020/jun/02/mississippi-governor-protests-good-no-place-agitat/">threatened the “full force of our state” to “deal with those who only want disorder and violence.”</a> At his Monday press conference, Reeves said the two groups were separate, calling the “anarchists and agitators from other parts of the county … spoiled kids who are privileged enough to not know consequences.”</p>

<p id="h175572-p26" class="permalinkable">But many protests over the last week have <a href="https://www.themarshallproject.org/2020/06/01/why-so-many-police-are-handling-the-protests-wrong"> turned violent after the intervention of police</a>, not “anarchists and agitators.” Videos from national news outlets and social-media feeds alike have shown a heavily armed police presence attacking and “kettling” otherwise peaceful protests in different cities around the country.</p>

<p id="h175572-p27" class="permalinkable">As for their goals, Brown and White understand the enormity of the social reform their movement is embarking upon. In the short term, they demand the voices of their community be heard. Beyond that, they stressed the need for significant, empowered representation for their community in policy and policing decisions.</p>

<p id="h175572-p28" class="permalinkable">White wants meaningful legislation on police brutality and violence, and a liaison between law enforcement and the communities they serve.</p>

<p id="h175572-p29" class="permalinkable">Brown also called for an end to the cultural signifiers of racism: symbols like Confederate Heritage Month, the present Mississippi flag and what she described as the overwhelming need to turn basic questions of human dignity into a debate.</p>

<p id="h175572-p30" class="permalinkable"><em>Email state reporter Nick Judin at <a href="/cdn-cgi/l/email-protection#c2acaba1a982a8a3a1a9b1adaca4b0a7a7b2b0a7b1b1eca1adaf"><span class="__cf_email__" data-cfemail="afc1c6ccc4efc5ceccc4dcc0c1c9ddcacadfddcadcdc81ccc0c2">[email&#160;protected]</span></a> and follow him @nickjudin.</em></p>

  
    
  </div>
  
  
  
  






     
      
        <!-- Go to www.addthis.com/dashboard to customize your tools --> <div class="addthis_inline_share_toolbox" style="margin-top:5px" align="center"></div>
      
    


  
  
  

  
  <div class="recommended">
    <h3>More stories by this author</h3>
    <ul>
      
      
        <li><a href="/news/2020/jun/01/mississippi-fully-reopens-today-after-biggest-week/">Mississippi Fully Reopens Today After Biggest Week of COVID-19 Cases, Yet</a></li>
      
        <li><a href="/news/2020/may/28/mississippi-fully-opening-covid-19-cases-grow-stat/">Mississippi Fully Opening as COVID-19 Cases Grow, State Naming Nursing Homes</a></li>
      
        <li><a href="/news/2020/may/27/covid-19-ummc-expert-emerging-knowledge-virus/">COVID-19: UMMC Expert on  Emerging Knowledge of the Virus</a></li>
      
        <li><a href="/news/2020/may/26/mississippi-deep-recession-facing-long-recovery-27/">Mississippi In Deep Recession Facing Long Recovery, 273 New Cases of COVID-19</a></li>
      
        <li><a href="/news/2020/may/22/mississippi-reports-402-new-covid-19-cases-admits-/">Mississippi Reports 402 New COVID-19 Cases, Admits Testing Totals Mix In Antibody Tests</a></li>
      
    </ul>
  </div>
  


<div align="center" style="border:1px dotted;padding: 5px;margin-bottom:10px;">
<a href="https://form.jotform.com/jacksonfreepress/vipannual"><img src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2020/04/23/Uplift_JFP6_t670.jpg" width="100%" /></a>
<h3>Thanks to all our new JFP VIPs!</h3>
<p style="font-family: Arial; Helvetica;"><strong>COVID-19 has closed down the main sources of the JFP's revenue -- concerts, festivals, fundraisers, restaurants and bars. <a href="https://form.jotform.com/jacksonfreepress/vipannual">If everyone reading this article gives $5 or more, we should be able to continue publishing through the crisis.</a> Please <a href="https://form.jotform.com/jacksonfreepress/vipannual">pay what you can</a> to keep us reporting and publishing.</strong></p>
</div>

  <div class="recommended">
<div class='mailmunch-forms-widget-387064'></div>
  </div>

  

  
    

<div id="comments"> 

  
  
    
    
    
      
      

<h3 class="header">Comments</h3>

  <p class="no_comments">Use the comment form below to begin a discussion about this content.</p>

      
    
  

  
  

    <div id="disqus_thread"></div>
    <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
        /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
        var disqus_shortname = 'jacksonfreepress'; // required: replace example with your forum shortname

        /* * * DON'T EDIT BELOW THIS LINE * * */
        (function() {
            var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
            dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
            (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
        })();
    </script>
    <noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
    <a href="https://disqus.com" class="dsq-brlink">comments powered by <span class="logo-disqus">Disqus</span></a>

    <script type="text/javascript">
    /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
    var disqus_shortname = 'jacksonfreepress'; // required: replace example with your forum shortname

    /* * * DON'T EDIT BELOW THIS LINE * * */
    (function () {
        var s = document.createElement('script'); s.async = true;
        s.type = 'text/javascript';
        s.src = '//' + disqus_shortname + '.disqus.com/count.js';
        (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
    }());
    </script>
    </div>
  


            
<div id="zergnet-widget-82895"></div>

<script language="javascript" type="text/javascript">
(function() {
var zergnet = document.createElement('script');
zergnet.type = 'text/javascript'; zergnet.async = true;
zergnet.src = (document.location.protocol == "https:" ? "https:" :
"http:") + '//www.zergnet.com/zerg.js?id=82895';
var znscr = document.getElementsByTagName('script')[0];
znscr.parentNode.insertBefore(zergnet, znscr);
})();
</script>


          </div>
        

        
          <div class="sidebar">
            


            
    

    

<div>

<h3>COVID-19 Coverage</h3>

<p><a href="http://jacksonfreepress.com/coronavirus/"><img src="https://jacksonfreepress.media.clients.ellingtoncms.com//img/photos/2020/03/19/COVID_Banner.jpg" width="300px" /></a><br />See our archive of <a href="http://jacksonfreepress.com/coronavirus/">continuing coverage of COVID-19</a> in Jackson and Central Mississippi. We're actively updating these threads: <a href="https://www.jacksonfreepress.com/news/2020/mar/12/event-cancelations-due-covid-19/">Event Cancellations</a> and <a href="https://www.jacksonfreepress.com/news/2020/mar/18/jackson-restaurants-offering-curbside-service/">Curbside Restaurant Service</a>.</p>

<h3>Join JFP VIP During COVID-19</h3>
<p><a href="https://form.jotform.com/jacksonfreepress/vipannual"><img src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2020/04/23/Uplift_JFP6_t670.jpg" width="300px" /></a></p>
<p><strong>COVID-19 has closed down the main sources of our revenue -- concerts, festivals, fundraisers, restaurants and bars. <a href="https://form.jotform.com/jacksonfreepress/vipannual">If you appreciate our work, please become a JFP VIP.</a> We have a new "Pay What You Can" option--please <a href="https://form.jotform.com/jacksonfreepress/vipannual">pay what you can</a> to keep us publishing.</strong></p>
</div>

<!-- div class="section home-best-bets" style="width: 300px!important"> 
<div data-cswidget="8346" width="300px" > </div>
<script type="text/javascript" async defer src="//portal.CitySpark.com/js/widget.min.js" > </script>
</div>
<div -->

<!-- div>
<h3>Special Section</h3>
<p>
<a href="https://www.dropbox.com/s/yj68w4ydejo54rx/Camp_Guide_2017.pdf?dl=0"><img src="http://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2017/04/04/Camp_Cover_2017_t670.jpg" /></a>
</p>
</div -->

    

<h3>Sponsors</h3>
 
<!-- /1024782/Top_300_250 -->
<div class="ad">
<div id='div-gpt-ad-1550259823887-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1550259823887-0'); });
</script>
</div>
</div>

    <!--  TWITTER
    =========================================================================================== -->
    <div class="twitter_module">
        <h3>JFP Tweets</h3>
        <div id="twitter"></div>

<a class="twitter-timeline" href="https://twitter.com/JxnFreePress" data-widget-id="347027636788269058">Tweets by @JxnFreePress</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
        
  </div>

<div class="ad">
<!-- /1024782/Top_Skyscraper -->
<div id='div-gpt-ad-1550262894638-0' style='height:600px; width:160px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1550262894638-0'); });
</script>
</div>
</div>

 
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));
</script>

<div class="fb-like-box" data-href="http://www.facebook.com/jacksonfreepress" data-width="300" data-show-faces="true" data-border-color="#fff" data-stream="false" data-header="false"></div>

<div class="ad">
<!-- /1024782/Second_Skyscraper -->
<div id='div-gpt-ad-1550263161137-0' style='height:600px; width:160px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1550263161137-0'); });
</script>
</div>
</div>

<div id="RecentComments" class="dsq-widget">
 <h3>Recent Comments</h3>
 <script type="text/javascript" src="https://jacksonfreepress.disqus.com/recent_comments_widget.js?num_items=5&hide_mods=0&hide_avatars=1&avatar_size=0&excerpt_length=80"></script>
<p><a href="https://www.jacksonfreepress.com/comments/disqus">see recent 25 &raquo;</a></p>
</div>

<div class="ad">
<!-- /1024782/Second_300_250 -->
<div id='div-gpt-ad-1550263248411-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1550263248411-0'); });
</script>
</div>
</div>


          </div>
        
      
    </div>
  </div>
  

  
  <div id="footer">
    <div class="wrapper">
      
        

        <dl>
          <dt>Sections</dt>
          <dd>
            <a href="/news/all/">News</a>,
            <a href="/news/opinion/">Opinion</a>,
            <a href="/news/arts/">Arts</a>,
            <a href="/news/music/">Music</a>,
            <a href="/news/music/">Events</a>,
            <a href="/news/lifestyle/">Life+Style</a>,
            <a href="/news/food&drink/">Food+Drink</a>,
            <a href="/news/sports/">Sports</a>
          </dd>
          <dt>Events</dt>
          <dd>
            <a href="/events/">Events Calendar</a>,
            <a href="https://portal.cityspark.com/Account/PopLogin?ReturnUrl=%2fEventEntry%2fEventEntry%2fJacksonFreePress">Submit an Event</a>
          </dd>
          <dt>Media</dt>
          <dd>
            <a href="/photos/">Photos</a>,
            <a href="/photos/galleries/">Galleries</a>,
            <a href="/videos/">Videos</a>,
            <a href="/audioclips/">Audio</a>,
            <a href="/documents/">Documents</a>
          </dd>
          <dt>Advertise</dt>
          <dd>
            <a href="/advertise/">In the JFP</a>,
            <a href="http://www.jfpclassifieds.com/">Classifieds</a>,
            <a href="/cdn-cgi/l/email-protection#295d464d4d6943484a425a46474f5b4c4c595b4c5a5a074a4644">Email the Publisher</a>
          </dd>
          <dt>About</dt>
          <dd>
            <a href="https://www.jacksonfreepress.com/masthead/">Meet Our Staff</a>, <a href="https://www.jacksonfreepress.com/jobs/">Apply for a Job</a>
          </dd>
        </dl>
        <p >
        &copy; Jackson Free Press, Inc.<br/>
        <a href="/user-agreement/">User agreement and privacy statement.</a><br/>
        phone: 601-362-6121 (ext 11 sales, ext 16 editorial, ext 17 publisher)<br/>
        fax: 601-510-9019<br/>
        125 S. Congress St. #1324 * Jackson, MS * 39201
        </p>

<!-- Analytics -->

        <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">

              var _gaq = _gaq || [];
              _gaq.push(['_setAccount', 'UA-792151-1']);
              _gaq.push(['_setDomainName', 'jacksonfreepress.com']);
              _gaq.push(['_trackPageview']);

              (function() {
                var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
              })();

              /*
                Meebo("domReady");
                */

        </script>

      
    </div>
  </div>
  

</div>


<!-- GetSiteControl Script -->
<script>
  (function (w,i,d,g,e,t,s) {w[d] = w[d]||[];t= i.createElement(g);
    t.async=1;t.src=e;s=i.getElementsByTagName(g)[0];s.parentNode.insertBefore(t, s);
  })(window, document, '_gscq','script','//widgets.getsitecontrol.com/165599/script.js');
</script>


<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-58KldfcjIY_EY"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-58KldfcjIY_EY.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->

<script type="text/javascript" class="teads" async="true" src="//a.teads.tv/page/70244/tag"></script>

<!-- Go to www.addthis.com/dashboard to customize your tools --> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=jacksonfreepress"></script> 

<script type="text/javascript" src="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/javascript/lib/cookies.js"></script>

  <script type="text/javascript" src="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/javascript/lib/mobile_detect.js"></script>

  <script>

     var cookie_value = Ellington.Cookies.get_cookie('template_preference');

     var domain  = "http://www.jacksonfreepress.com";

        if (cookie_value === null) {

          if (Ellington.TabletDetect()) {

            Ellington.Cookies.set_cookie('template_preference', 'mobile');

               window.location.href = domain.replace('www', 'm') + window.location.pathname;

          }

          if (Ellington.MobileDetect()) {

            Ellington.Cookies.set_cookie('template_preference', 'mobile');

               window.location.href = domain.replace('www', 'm') + window.location.pathname;


          }

        } else if (cookie_value == 'mobile' || cookie_value == 'tablet') {

               window.location.href = domain.replace('www', 'm') + window.location.pathname;


        }

  </script>

<script src="https://my.hellobar.com/1b1209fae4614f70b9e839d5864cadd2c8ffae91.js" type="text/javascript" charset="utf-8" async="async"></script>

</body>
</html>
