
<!DOCTYPE html>

<html lang="en" xmlns:og="http://opengraphprotocol.org/schema/">

<head>

<script async type="text/JavaScript" src="https://assets.publicgood.com/pgm/v1/dpg.js"></script>

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');

fbq('init', '533049636824431');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=533049636824431&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

<!-- Mobile-opt-in stuff here -->
<script type="text/javascript">
	var STATIC_MEDIA_URL = 'https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/';
</script>

  <script type="text/javascript" src="https://google.com/maps/api/js?sensor=true"></script>
  <script type="text/javascript" src="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/min.js"></script>
  
  <script type="text/javascript" src="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/javascript/thirdparty/wmd.js"></script>
  <script type="text/javascript" src="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/javascript/onload.js"></script>

<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="google-site-verification" content="IWXFYfZIttPjrHp6PHTaRrN9WFAh-rc2CZiQeV0pHiU" />

  <title>Amazing Teens 2021 | Jackson Free Press | Jackson, MS</title>
  
  
  
  <meta name="description" content="This year&#39;s Amazing Teens have all accomplished something that not many can claim: They completed the entirety of the last school year in the midst of a pandemic.">
  <meta property="og:title" content="Amazing Teens 2021">
  <meta property="og:type" content="article">
  <meta property="og:url" content="http://www.jacksonfreepress.com/news/2021/may/05/amazing-teens-2021/">
  <meta name="twitter:card" content="summary_large_image">
  <meta name="twitter:site" content="@jxnfreepress">
  <meta name="twitter:title" content="Amazing Teens 2021">
  <meta name="twitter:description" content="This year&#39;s Amazing Teens have all accomplished something that not many can claim: They completed the entirety of the last school year in the midst of a pandemic. ">
<meta name="twitter:image" content="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Elliot-Stephen_Blaylock-Photography_web.jpg">




  <link rel="shortcut icon" type="image/x-icon" href="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/jacksonfreepress/2.3.0/images/jfp_favicon.ico">
  <link rel="stylesheet" href="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/min.css" type="text/css" media="screen, print">
  <link rel="stylesheet" href="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/jacksonfreepress/2.3.0/stylesheets/print.css" type="text/css" media="print">
  
  <!--[if IE 6]><link rel="stylesheet" href="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/stylesheets/ie6.css" type="text/css" media="screen"><![endif]-->
  <!--[if IE 7]><link rel="stylesheet" href="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/stylesheets/ie7.css" type="text/css" media="screen"><![endif]-->  

  
    <link rel="stylesheet" href="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/jacksonfreepress/2.3.0/jfp-less/mod.css" type="text/css" media="screen">


  <script type="text/javascript">
    var STATIC_MEDIA_URL = 'https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/';
  </script>
  

<!-- GOOGLE AD SCRIPT -->

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/1024782/Top_Banner', [728, 90], 'div-gpt-ad-1550259565865-0').addService(googletag.pubads());
    googletag.defineSlot('/1024782/Top_300_250', [300, 250], 'div-gpt-ad-1550259823887-0').addService(googletag.pubads());
    googletag.defineSlot('/1024782/Top_Skyscraper', [160, 600], 'div-gpt-ad-1550262894638-0').addService(googletag.pubads());
    googletag.defineSlot('/1024782/Second_Skyscraper', [160, 600], 'div-gpt-ad-1550263161137-0').addService(googletag.pubads());
    googletag.defineSlot('/1024782/Second_300_250', [300, 250], 'div-gpt-ad-1550263248411-0').addService(googletag.pubads());
    googletag.enableServices();
  });
</script>

<!-- /GOOGLE AD SCRIPT -->

<!-- Typekit -->
    <script type="text/javascript" src="https://use.typekit.com/dzz7rzp.js"></script>
    <script type="text/javascript">try{Typekit.load();}catch(e){}</script>
<!-- /.Typekit-->


  


  <script type="text/javascript">
    
    jQuery(document).ready(function() {
      jQuery("#legacy-comments h1").html('Previous Comments <span class="lone-link">show</span>');
      jQuery("#legacy-comments h1").after('<p class="whatthis highlight-type">What\'s this?</p>');
      jQuery("#legacy-comments h1").css("border-bottom", "0");
      jQuery(".legacy-comment").hide();


      jQuery('#legacy-comments p.whatthis').click(function() {
        alert('In 2012 the Jackson Free Press moved to a new website. The system did not support old comments becoming new comments, so we placed them here. In many cases, these comments are as meaningful as the story that inspired them.');
      });

      /* Reformat legacy-comment-dates */
      jQuery('span.legacy-comment-date').each(function() {
        var html = jQuery(this).html().substring(0,10);
        var d = jQuery.datepicker.parseDate('yy-mm-dd', html);
        var s = jQuery.datepicker.formatDate("M d yy", d);
        jQuery(this).html(s);
      });

      /* toggle the componenet with class msg_body */
      jQuery("#legacy-comments h1").click(function() {
        jQuery(".legacy-comment").slideToggle(500);
        if (jQuery("#legacy-comments h1 span.lone-link").html() == 'show') {
          jQuery(this).html('Previous Comments <span class="lone-link">hide</span>');
        } else {
          jQuery(this).html('Previous Comments <span class="lone-link">show</span>');
        };
      });

    });

    $(document).ready(function() {

      var h3 = $("h3:contains('Previous Comments')");
      /* Setup classes */
      h3.nextAll('dl').addClass('previous-comment');
      h3.nextAll('hr').remove();

      /* Add Elements */
      h3.css('margin-top','20px');
      h3.css('cursor','pointer');
      h3.append('<span class="previous-comment-toggle lone-link">show</span>');
      h3.after('<span class="whatthis">What\'s this?</span>');
      $(".previous-comment").hide();

      /* Remove and rearrange elements */
      $(".previous-comment").each(function(){
        $(this).children('dt').remove();
        $(this).children('dd').first().remove();
        var html = $(this).children('dd').last().html().substring(0,10);
        var d = $.datepicker.parseDate('yy-mm-dd', html);
        var s = $.datepicker.formatDate("M d yy", d);
        $(this).children('dd').last().html(s);
      });

      /* Add Effects */
      $('span.whatthis').click(function() {
        alert('In 2012 the Jackson Free Press moved to a new website. The system did not support old comments becoming new comments, so we placed them here. In many cases, these comments are as meaningful as the story that inspired them.');
      });

      /* toggle the componenet with class msg_body */
      h3.click(function() {
        $(".previous-comment").slideToggle(500);
        if ($(".previous-comment-toggle.lone-link").html() == 'show') {
          $(".previous-comment-toggle.lone-link").html('hide');
        } else {
          $(".previous-comment-toggle.lone-link").html('show');
        };
      });


    });



  </script>


  
  <link type="application/rss+xml" rel="alternate" href="/rss/comments/objects/147/44808/">

  
  <meta name="viewport" content="width=1020">
  

<!-- MailMunch for Jackson Free Press -->
<!-- Paste this code right before the </head> tag on every page of your site. -->
<script src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-mailmunch-site-id="293557" async="async"></script>

<style>
.converted-anchor {display:none !important;}
</style>

</head>

<body class="news story_detail revision" id="story_44808">

<div id="page">

  
  <div id="toolbar">
    <div class="wrapper">
      
        
  <ul>
    <li class="news"><a href="/">JFP</a></li>
    <li class="news"><a href="http://jfp.ms/vip/">Be a JFP VIP</a></li>
    <li class="news"><a href="http://www.bestofjackson.com/">Best of Jackson</a></li>
    <li class="news"><a href="/news/newsletter/">JFPDaily</a></li>
    <li class="news"><a href="/advertise/">Advertise</a></li>
    <li class="news"><a href="/contact/">Contact</a></li>
	<li class="news"><a href="/awards/">Awards</a></li>
  </ul>

        
<ul class="user">
    <li class="search">
        <form action="/search/" method="get" class="search_form" autocomplete="off">
            <p class="query"><input type="text" name="q" placeholder="search" value=""></p>
        </form>
    </li>
    
        <li><a href="/accounts/login/?next=/news/2021/may/05/amazing-teens-2021/">Sign in</a></li>
    
</ul>

      
    </div>
  </div>
  

  
  <div id="header">
    <div class="wrapper">
      
<div class="branding">
        <h1><a href="/">Jackson Free Press<!-- <span class="jfp">JFP</span><span class="ms">.ms</span> --></a></h1>
        <p><a href="#body">Jump to content</a></p>
</div>

<div class="ad">

<!-- /1024782/Top_Banner -->
<div id='div-gpt-ad-1550259565865-0' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1550259565865-0'); });
</script>
</div>

</div>

</div>

    </div>
  </div>
  

  
  <div id="nav">
    <div class="wrapper">
      
    <ul class="upper">
        <li class="l1"><a href="/news/all">News</a>
            <ul class="u1">
                <li class="l1"><a href="/news/all/">Home</a></li>
                <li class="l1"><a href="/news/justice/">Justice</a></li>
                <li class="l2"><a href="/news/education/">Education</a></li>
                <li class="l3"><a href="/news/politics/">Politics</a></li>
                <li class="l4"><a href="/news/business/">Business</a></li>
                <li class="l5"><a href="/news/people/">People</a></li>
                <li class="l6"><a href="/news/media/">Media</a></li>
                <li class="l7"><a href="http://blogs.jacksonfreepress.com/">Jackblog</a></li>
                <li class="l6"><a href="/news/covers/">Covers</a></li>
            </ul>
        </li>
        <li class="l2"><a href="/news/opinion">Opinion</a>
            <ul class="u2">
                <li class="l1"><a href="/news/opinion">Home</a></li>
                <li class="l2"><a href="/weblogs/">Weblogs</a></li>
            </ul>
        </li>
        <li class="l3"><a href="/news/arts/">Arts</a>
            <ul class="u3">
                <li class="l1"><a href="/news/arts/">Home</a></li>
                <li class="l1"><a href="/news/film/">Film</a></li>
                <li class="l2"><a href="/news/books/">Books</a></li>
                <li class="l3"><a href="/news/art/">Art</a></li>
                <li class="l4"><a href="/news/theater/">Theater</a></li>
                <li class="l5"><a href="/news/dance/">Dance</a></li>
            </ul>
        </li>
        
        <li class="l4 upper"><a href="/news/music/">Music</a>
            <ul class="u4">
                <li class="l1"><a href="/news/music/">Home</a></li>
                <li class="l2"><a href="/news/music/listings/">Music Listings</a></li>
		<li class="l4"><a href="/places/music-venue/">Music Venues</a></li>
                <li class="l5"><a href="/bands/">Local Bands</a></li>
                <li class="l6"><a href="/weblogs/music/">Music Blog</a></li>
            </ul>
        </li>

        <li class="l5 upper"><a href="/calendar/">Calendar</a>
            <ul class="u5">
                <li class="l1"><a href="/calendar/">Happening Today</a></li>
                <li class="l3"><a href="/events/exhibits/">Ongoing Exhibits</a></li>
                <li class="l4"><a href="/galleries/">Galleries</a></li>
                <li class="l5"><a href="/events/ongoing/">Other Ongoing Events</a></li>
            </ul>
        </li>

        
        <li class="l6"><a href="/news/lifestyle/">Life+Style</a>
            <ul class="u6">
                <li class="l1"><a href="/news/lifestyle/">Home</a></li>
                <li class="l2"><a href="/news/bodysoul/">Body+Soul</a></li>
                <li class="l3"><a href="/news/good/">GOOD Ideas</a></li>
                <li class="l2"><a href="/news/faith/">Faith</a></li>
                <li class="l4"><a href="/news/home-garden/">Home & Garden</a></li>
                <li class="l5"><a href="/news/hitched/">Hitched</a></li>
                <li class="l6"><a href="/news/flystyle/">Fly! Style</a></li>
                <li class="l5"><a href="/news/girl-about-town/">Girl About Town</a></li>
                <li class="l4"><a href="/news/running-recreation/">Running & Recreation</a></li>
                <li class="l3"><a href="/news/travel/">Travel</a></li>
                
            </ul>
        </li>
        <li class="l7"><a href="/news/food&drink/">Food+Drink</a>
            <ul class="u7">
                <li class="l1"><a href="/news/food&drink/">Home</a></li>
                <li class="l2"><a href="/restaurants/">Restaurants</a></li>
                <li class="l3"><a href="/weblogs/food/">Food Blog</a></li>
            </ul>
        </li>
        <li class="l8"><a href="/news/sports/">Sports</a>
            <ul class="u8">
                <li class="l1"><a href="/news/sports/">Home</a></li>
                <li class="l2"><a href="/sports/the_slate">Slate - Schedule</a></li>
                <li class="l3"><a href="/categories/news/bryans-rant">Bryan's Rant</a></li>
                <li class="l4"><a href="/weblogs/sports/">Sports Blog</a></li>
            </ul>
        </li>
        
    </ul>


    </div>
  </div>

  

  



  
    
    
    

    
  

  <div class="breadcrumbs">
    
  </div>

  
  <div id="body">
    <div class="wrapper">
      
        
        
        

        
          <div class="content_title">
            
  <div id="target-story_headline_template">
  
    <h2 class="header">Amazing Teens 2021</h2>
    
      
    
  
  </div>

          </div>
        

        
        

        
          
          <div class="content">
            

            
              
                 
              
            

              
  
    
    <div class="story_lead_photo">
      <div class="photo">
        
        <a href="/photos/2021/may/05/38835/"><img src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Elliot-Stephen_Blaylock-Photography_web_t670.jpg?b3f6a5d7692ccc373d56e40cf708e3fa67d9af9d" alt="Elliot Stephen Photo courtesy Blaylock Photography"></a>
        
      </div>
      <p class="caption">
        Elliot Stephen Photo courtesy Blaylock Photography
        
      </p>
    </div>
    
  

  <div class="content_info">
    

<span class="byline">
    
        
            
                
                    By <a href="/staff/jfp-staff/">JFP Staff</a>
                
            
        
    

    
</span>

      <span class="datetime">
        <a href="/news/2021/may/05/amazing-teens-2021/">
          Wednesday, May 5, 2021 2:22 p.m. CDT
        </a>
      </span>

    
    

<div class="vote_box">
	<form action="/accounts/login/?next=/news/2021/may/05/amazing-teens-2021/" method="post" class="vote_form single is_anonymous"><input type='hidden' name='csrfmiddlewaretoken' value='71M3zYkg5TUEQG2VuH2ZFsT64YrMC4MQ' />
	  <button class="upvote " type="submit" name="value" value="1">Upvote</button>
	  
	  <span class="vote_count">0</span>
	  <input type="hidden" name="content_type" value="147">
	  <input type="hidden" name="object_id" value="44808">
	</form>
</div>

  </div>

  
  <div class="story_body" id="target-story_body_template">
    <p id="h183403-p1" class="permalinkable">This year's Amazing Teens have all accomplished something that not many can claim: They completed the entirety of the last school year in the midst of a pandemic. For their perseverance, the Jackson Free Press recognizes these students from the Jackson metro who embody excellence in all that they do, and we believe that their dedication in the face of hardship will propel them even further as they ponder the next stages of their lives.</p>

<p id="h183403-p2" class="permalinkable"><strong>Samuel Wheat</strong></p>




<div class="inline inline_photo inline-right  ">
  <p class="thumbnail">
    <a href="/photos/2021/may/05/38837/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Samuel-Wheat_cred-TeMaK-Photo_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Photo courtesy TeMaK Photo</p>
    
  </div>
</div>


<p id="h183403-p3" class="permalinkable">When Samuel Wheat crosses the stage to receive his high-school diploma from Murrah High School this May, he'll mark the end of his time in the Jackson Public School District, where he has attended since kindergarten. JPS, however, will have given Wheat a parting gift in addition to his diploma: a love for dance.</p>

<p id="h183403-p4" class="permalinkable">"Back in fourth grade, I got into the Power APAC dance program," Wheat recalls. "So (my senior year) marks the eighth year I've been in the program."</p>

<p id="h183403-p5" class="permalinkable">During his eight-year tenure in the program that teaches ballet, jazz and modern dance techniques to area students, Wheat has gotten to see more of the country, travelling to Birmingham, Ala., to perform in the Alabama Dance Festival and visiting Cincinnati, Ohio, as part of a scholarship he earned through Power APAC.</p>

<p id="h183403-p6" class="permalinkable">Ultimately, Wheat credits his instructors for inspiring him to finish out the program. "I've always felt comfortable with them," he says. "It's a loving community of people there, and there's a lot to learn." His teachers also reminded him that he had many opportunities to learn outside of the studio, too, encouraging him to enroll in AP classes.</p>

<p id="h183403-p7" class="permalinkable">"Being in APAC, I felt like going to AP was the next step," Wheat says of his choice to take on more challenging coursework. "I wanted to work for a college credit and strive toward higher learning." Wheat hopes to use these college credits towards a degree in dance. He admits that he isn't sure which college he is planning to attend, though USM, Belhaven and Hinds Community College are all in the running. "They've just got to give me a little more scholarship money," he quips. —Taylor McKay Hathorn</p>

<p id="h183403-p8" class="permalinkable"><strong>Mauricsa Woods</strong></p>




<div class="inline inline_photo inline-right  ">
  <p class="thumbnail">
    <a href="/photos/2021/may/05/38838/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Mauricsa-Woods_cred-Keila-Adams-Photography_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Photo courtesy Keila Adams Photography</p>
    
  </div>
</div>


<p id="h183403-p9" class="permalinkable">Mauricsa Woods, who has operated Tootie's Trendy Treats since she was 13, takes every lesson from her microeconomics and business-management classes to heart. "(Those classes) have been quite helpful with what I should expect when I open my storefront," Woods says.</p>

<p id="h183403-p10" class="permalinkable">The Tougaloo Early College High School rising senior presently runs the confectionery out of her kitchen but hopes to establish a physical location for Tootie's in the immediate future. Juggling a homespun business with her other responsibilities, though, has taught Woods important lessons. "I have really good time-management skills," she says. "I have to put aside time for each different thing that I do."</p>

<p id="h183403-p11" class="permalinkable">One such time commitment includes her membership in the Disney Dreamer program, which Steve Harvey and Essence Magazine sponsor. Although the COVID-19 pandemic cut the 2020 program short, Disney transitioned its Dreamers to a four-month online mentorship program, allowing them to form relationships with experts in the students' fields of interest. The program paired Woods with Chef Carla Hall, which she says was "definitely the highlight of the program."</p>

<p id="h183403-p12" class="permalinkable">Hall has helped Woods keep a pulse on the nation's baking and pastry scene, as she's presently interested in attending classes offered by the Culinary Institute of America in Hyde Park, N.Y., and NOCHI in New Orleans, La. College remains high on her priority list, though, evidenced by her recent application to the Mississippi University for Women, where she hopes to study at the Culinary Arts Institute and foster her love for writing and photography. —Taylor McKay Hathorn</p>

<p id="h183403-p13" class="permalinkable"><strong>Mehm Ha</strong></p>




<div class="inline inline_photo inline-right  ">
  <p class="thumbnail">
    <a href="/photos/2021/may/05/38839/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/mehm_ha_toy_courtesy_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Photo courtesy Mehm Ha</p>
    
  </div>
</div>


<p id="h183403-p14" class="permalinkable">Mehm Ha's freshman year at Callaway High School was his first year at an American high school, as he and his family had emigrated from Malaysia earlier that same year. "It wasn't easy. It was actually terrifying," Ha says of the experience. "But I had a lot of great teachers, and I get a lot of help at my house. I also do a lot of self-study."</p>

<p id="h183403-p15" class="permalinkable">His commitment to his schoolwork has helped Ha broaden his English vocabulary, with the high-school senior citing reading books and listening to music as his favorite ways to learn his new country's language. "Westlife is my favorite band," Ha reflects. "But I'll listen to any music—it doesn't matter."</p>

<p id="h183403-p16" class="permalinkable">Music keeps him energized as he scores goals on CHS's varsity soccer team, where he's been a member of the left-wing offense for four years. "When I first got here, I didn't know anybody, and I was in a coach's world geography class. He asked me if I wanted to join the team, so I tried out," Ha says of his early involvement with the team.</p>

<p id="h183403-p17" class="permalinkable">Athletics opened the door for further opportunities at the Jackson high school, and he now serves as a peer tutor. "I do a lot of subjects," Ha states. "I'm good at science and math, and I've improved in English. I tell (my classmates) that you've got to read about what you like, so that helps them build their vocabulary."</p>

<p id="h183403-p18" class="permalinkable">Ha did bring parts of his old culture with him, though, saying that he "learned a lot about computers" while living in Malaysia and plans to parlay that knowledge into a career as a computer data scientist. "I hope to work for NASA someday," Ha concludes. —Taylor McKay Hathorn</p>

<p id="h183403-p19" class="permalinkable"><strong>Elliott Stephen</strong></p>




<div class="inline inline_photo inline-right  ">
  <p class="thumbnail">
    <a href="/photos/2021/may/05/38835/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Elliot-Stephen_Blaylock-Photography_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Elliot Stephen Photo courtesy Blaylock Photography</p>
    
  </div>
</div>


<p id="h183403-p20" class="permalinkable">When the time came for the seniors at St. Joseph Catholic High School to vote on this year's superlatives, Elliott Stephen's classmates voted him "most talented," which Stephen believes stems from his involvement in the school's bowling league, swim team, golf team and marching band. "I've done all of those things basically my whole time at St. Joe," Stephen says, though he does acknowledge that bowling has been his favorite of the three.</p>

<p id="h183403-p21" class="permalinkable">"You're having fun, but there's still a serious feel to it," Stephen says. "It also has some long trips involved." Despite those long trips—many of which come with 5:30 a.m. arrival times at rival schools—the athlete says that his teammates make the bus rides fun. He has also enjoyed the travels he's made with his bandmates, with whom he has played bass guitar, alto saxophone, tenor drum, bass drum and snare drum, noting with a laugh that he "hasn't managed to play them all at the same time," though.</p>

<p id="h183403-p22" class="permalinkable">When he isn't representing the local parochial school at various athletic or musical events, Stephen enjoys volunteering with his local parish, St. Richard's, which supports area soup kitchens through fundraising and by donating volunteer hours. He is also gearing up to start college at the University of Southern Mississippi this fall, where he hopes to follow his mother's footsteps into the nursing profession. "She really didn't make me or pressure me into it," Stephen reflects. "But she did tell me I would be a good nurse, and I also want to do something that will help people." —Taylor McKay Hathorn</p>

<p id="h183403-p23" class="permalinkable"><strong>Priyadarshini "Priya" Ray</strong></p>




<div class="inline inline_photo inline-right  ">
  <p class="thumbnail">
    <a href="/photos/2021/may/05/38840/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Priya-Ray_courtesy_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Photo courtesy Priyadarshini Ray</p>
    
  </div>
</div>


<p id="h183403-p24" class="permalinkable">While Priyadarshini "Priya" Ray's already-packed resume now boasts the title of valedictorian of her graduating class at Jackson Academy, the student asserts that earning the top-student position stems from her forward-thinking ambitions. "Making good grades was the goal for me because it'a a big part of the college admissions process," she says.</p>

<p id="h183403-p25" class="permalinkable">Nevertheless, Ray applauds her classmates for their commitment to collaboration in the pursuit of academic excellence. "I think teaching each other helped us achieve better understanding," she says. "It allows you to look at every single concept with multiple perspectives."</p>

<p id="h183403-p26" class="permalinkable">Ray had a knack for applying these concepts on standardized tests, qualifying to be a National Merit Finalist after scoring above Mississippi's selection index on the PSAT and submitting additional qualifying materials, including a resume, an essay and a letter of recommendation. "JA really helps you prepare for the PSAT," Ray says. "I honestly didn't even do too much studying on my own (because) JA really drilled the basic topics."</p>

<p id="h183403-p27" class="permalinkable">She also credits Jackson Academy with sharpening her writing skills, citing her 10th grade honors English course as her favorite. "Ms. McKay was tough on us," Ray recalls. "She had lots of rules: We couldn't use linking verbs or passive voice or the words 'this' or 'that.' It really challenged me and really transformed my writing."</p>

<p id="h183403-p28" class="permalinkable">The high-school senior will undertake yet another challenge this fall when she attends Georgetown University, where she plans to study biology in regard to global health. Although she'll be nearly 15 hours from her alma mater, Ray believes she'll find some commonalities between the two. "It's a closed campus, so you have a really good, tight-knit community while still being in an urban center with lots of opportunities," she says. —Taylor McKay Hathorn</p>

<p id="h183403-p29" class="permalinkable"><strong>Lilly Noble</strong></p>




<div class="inline inline_photo inline-right  ">
  <p class="thumbnail">
    <a href="/photos/2021/may/05/38841/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Lilly-Noble_courtesy_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Photo courtesy Lilly Noble</p>
    
  </div>
</div>


<p id="h183403-p30" class="permalinkable">When competing for a Miss Mississippi Outstanding Teen crown last year, Lilly Noble chose what she thought would be the perfect platform: today a reader, tomorrow a leader. "Mississippi actually ranks last nationally in literacy," she says of her choice to emphasize literacy. "We could do better, especially with all the amazing authors we have in the state."</p>

<p id="h183403-p31" class="permalinkable">To combat this disparity, Noble planned to spend her year as a titleholder traveling around the state reading to elementary school students, but when the pandemic struck, the now high-school senior was forced to rethink her project. "I created a website with videos of me reading to students, and I've done Zoom readings," Noble recalls. "It's inspiring to see kids get excited about reading."</p>

<p id="h183403-p32" class="permalinkable">The Jackson Preparatory School student has experienced that excitement herself, meeting her favorite author, Jacksonian Angie Thomas, at the Mississippi Book Festival two years ago. Thomas's debut novel, "The Hate U Give," is Noble's favorite, and she says that it opened her eyes to society's pervasive racism. "We can fix racism if we're aware of the problem," Noble claims. "We have to realize it's real and that it's around us."</p>

<p id="h183403-p33" class="permalinkable">Remedying societal ills is a passion for Noble, who will attend the University of Alabama to study pre-law this fall, a decision she made after interning with the Mississippi Center for Justice. "I want to do criminal defense for people who go to jail for a long time for minimal crimes," Noble says. "I want there to be people defending the people who need it most. Your jail time shouldn't be affected by how much you make at your job." —Taylor McKay Hathorn</p>

<p id="h183403-p34" class="permalinkable"><strong>Madison Temple</strong></p>




<div class="inline inline_photo inline-right  ">
  <p class="thumbnail">
    <a href="/photos/2021/may/05/38842/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Madi-Grace-Temple_courtesy_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Photo courtesy Madison Temple</p>
    
  </div>
</div>


<p id="h183403-p35" class="permalinkable">Madison Temple did something twice during her high-school career that many students never do once: win a state championship. "We had always gotten second place and had always lost by just a few points," Temple says of her dance team's early attempts at bringing home a state title. "But sitting on the floor and hearing them call your name—chills go down your back. It's crazy."</p>

<p id="h183403-p36" class="permalinkable">The second time was just as special for the Pearl High School senior, who lamented the graduation of several "great seniors" between the first and second championships, saying, "It's one thing to get to first place, but it's harder to stay there. We were able to do it, though."</p>

<p id="h183403-p37" class="permalinkable">Now that it's her turn to graduate, Temple looks with fondness on her memories of the Pearl Public School District, where she's attended since Kindergarten. "The people at every school in this district get so involved with you, and you can see that they actually care about what they're doing," Temple reflects. "It means a lot to see that, and it's like we're a big family."</p>

<p id="h183403-p38" class="permalinkable">She plans to join a new family this fall, as she has been accepted into Jones College in Ellisville, Miss. where she will be a member of the "Touch of Gold" dance team while studying health-related professions in pursuit of her dream of being an oncology nurse.</p>

<p id="h183403-p39" class="permalinkable">The oncology ward already holds a special place in her heart, as her mother was diagnosed with breast cancer when she was in second grade. "I've seen how the nurses and doctors have helped my family," Temple says. "I want to give back and help other families." —Taylor McKay Hathorn</p>

<p id="h183403-p40" class="permalinkable"><strong>Christopher Brown</strong></p>




<div class="inline inline_photo inline-right  ">
  <p class="thumbnail">
    <a href="/photos/2021/may/05/38843/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Christopher-Brown2_courtesy_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Photo courtesy Christopher Brown</p>
    
  </div>
</div>


<p id="h183403-p41" class="permalinkable">When Christopher Brown was placed in a JROTC class as an elective his ninth grade year, he never expected to be named the school's cadet of the year nearly three years later. "It started out as something simple," Brown reflects. "But I was chosen as superior cadet my 10th grade year, and I was named cadet of the year this year."</p>

<p id="h183403-p42" class="permalinkable">The title comes with a weighty responsibility, as Brown will take over the top post in the school's JROTC program during his senior year. "I feel like they put a lot of trust in me as a leader," Brown says of the position. "They know I'll lead us the right way."</p>

<p id="h183403-p43" class="permalinkable">The high-school junior is no stranger to leadership, having participated in a service-learning program at Wilkins Elementary School during his freshman and sophomore years. "We got to help the students in the class," Brown recalls. "The students were getting to actually interact and have fun with what they were learning."</p>

<p id="h183403-p44" class="permalinkable">Brown hopes that his cohort's time at the elementary school will send a positive message about Wingfield High School to the local community. "I hope they see us as a giving school," he says. "We want to participate in our community and support them, and we want them to support us, too. We invite the community to participate in everything we do."</p>

<p id="h183403-p45" class="permalinkable">Once he graduates in May 2022, Brown plans to continue to positively represent his alma mater by attending college at Mississippi State University, where he says that he hopes to graduate debt-free with a degree in engineering. —Taylor McKay Hathorn</p>

<p id="h183403-p46" class="permalinkable"><strong>Devin Ard</strong></p>




<div class="inline inline_photo inline-right  ">
  <p class="thumbnail">
    <a href="/photos/2021/may/05/38844/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Devin_Ard_courtesy_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Photo courtesy Devin Ard</p>
    
  </div>
</div>


<p id="h183403-p47" class="permalinkable">Devin Ard has fond memories of attending Jackson State University games with his mother. There he would watch in awe as the band performed in the stands and on the field. He now hopes to soon be suiting up to join them.</p>

<p id="h183403-p48" class="permalinkable">Ard hasn't always dreamed of being in the band. The young athlete grew up playing sports. In fact, the summer before his freshman year of high school he made the Jim Hill High School basketball team. But when he went to play basketball in Georgia for the summer, he missed the team's summer workouts and lost his spot on the roster.</p>

<p id="h183403-p49" class="permalinkable">"I had to do something because I couldn't just sit at home after school every day, so I got into the band with my friend," he says. "Ever since then, I've really found a passion for music."</p>

<p id="h183403-p50" class="permalinkable">Ard joined the band as a freshman without having ever played an instrument. He knew nothing about marching in a band or reading music. With the help of band director Christopher Little, he learned to play the baritone within a school year. Soon after, he also learned to play the euphonium and became a leader in the brass section. After his sophomore year, his peers nominated for the position of drum major.</p>

<p id="h183403-p51" class="permalinkable">"It was something that became natural," he says. "I was looked upon as a leader."</p>

<p id="h183403-p52" class="permalinkable">In addition to leading the band, Ard is also a member of the National Honor Society. Going forward, he aims to become a doctor of sports medicine. He also aspires to one day help redevelop the West Jackson area by purchasing and redeveloping blighted properties. —Torsheta Jackson</p>

<p id="h183403-p53" class="permalinkable"><strong>Reid Hewitt</strong></p>




<div class="inline inline_photo inline-right  ">
  <p class="thumbnail">
    <a href="/photos/2021/may/05/38845/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Reid-Hewitt_courtesy_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Photo courtesy Reid Hewitt</p>
    
  </div>
</div>


<p id="h183403-p54" class="permalinkable">Reid Hewitt is passionate about criminal-justice reform. The topic became personal to the 17-year-old after a family member found themselves in and out of the prison system.</p>

<p id="h183403-p55" class="permalinkable">"I was wondering, 'It's not necessarily for violent crimes, so why does it continue to happen?' I started researching statistics and how many Black people make up the prison population in the United States," she says. "It really started to hit me the more research that I did."</p>

<p id="h183403-p56" class="permalinkable">Hewitt's research revealed that Blacks were disproportionately arrested and jailed in comparison to other races.</p>

<p id="h183403-p57" class="permalinkable">She and a classmate produced a mini-documentary titled "Mass Incarceration" for their Advanced Placement Language and Composition class. They submitted the piece, which focused on mass incarceration, as an entry in the CSPAN's StudentCam Competition. Hewitt also recently submitted an essay on the relationship between equality and justice for the Bill of Rights Institute's "We the Students'' essay contest and hosted a podcast discussing identity and race.</p>

<p id="h183403-p58" class="permalinkable">The Madison Central High School junior is a member and officer of numerous student organizations and serves as teen president for the Jackson, Miss., chapter of Jack and Jill of America, Inc. Hewitt maintains a 4.02 GPA while enrolling in advanced-placement and dual-credit courses. She plans to attend an HBCU and major in business finance before moving on to law school. She hopes to one day work as a sports and entertainment lawyer.</p>

<p id="h183403-p59" class="permalinkable">Hewitt hopes her work shines a light on the injustices and inequalities in the criminal-justice system.</p>

<p id="h183403-p60" class="permalinkable">"I plan to take everything that I learned and created from my documentary and all the research that I've collected and really put that into action. I plan to use the positions that I am in and the roles that I will be in in the future to create some type of real change." —Torsheta Jackson</p>

<p id="h183403-p61" class="permalinkable"><strong>Joseph Anthony</strong></p>




<div class="inline inline_photo inline-right  ">
  <p class="thumbnail">
    <a href="/photos/2021/may/05/38846/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Joseph-Anthony2_cred-Gary-Davis_gshotspics_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Photo courtesy Gary Davis/gshotspics</p>
    
  </div>
</div>


<p id="h183403-p62" class="permalinkable">Since his early elementary school years, Joseph Anthony's parents instilled in him the importance of education, which remains a priority to the Provine High School senior to this day. The National Honor Society at Powell Middle School inducted him into their ranks, and he earned the title of salutatorian during eighth grade. Now in his final year of high school, Anthony boasts a perfect GPA.</p>

<p id="h183403-p63" class="permalinkable">In addition to academic performance, Anthony engages in extracurricular activities as well, playing the tuba as a head section leader in Provine's marching and concert band while also serving on the school's soccer and track teams. "This academic year (has been) totally different with the schools going virtual, but I managed alongside God. I prayed that He keep me focused so that I could stay on track," he says.</p>

<p id="h183403-p64" class="permalinkable">His relationships with his classmates earned him the title of Mr. Provine this year. "I was so elated that my peers thought enough of me to be one of the faces of the school, and I thank them for that," he says.</p>

<p id="h183403-p65" class="permalinkable">Anthony credits God for all of his accomplishments, such as his recent induction into the Phi Theta Kappa Honor Society. In his church, Anthony serves as a youth Sunday school secretary, assistant Sunday school financial secretary and youth Sunday school superintendent. His openness toward giving himself to God coincides with his philanthropic passions. "I love to help the homeless. Prior to the pandemic, my brother and I would regularly go feed the homeless. We would also go to Matt's House, a shelter for women and children where we'd clean and organize their pantry." —Mike McDonald</p>

<p id="h183403-p66" class="permalinkable"><strong>Jamarion Gipson</strong></p>




<div class="inline inline_photo inline-right  ">
  <p class="thumbnail">
    <a href="/photos/2021/may/05/38847/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Jamarion-Gipson_courtesy_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Photo courtesy Jamarion Gipson</p>
    
  </div>
</div>


<p id="h183403-p67" class="permalinkable">Jamarion Gipson sees himself as both a designer and an entrepreneur, creating graphic logos for businesses while simultaneously marketing his name. After a cousin's friend commissioned him to create designs for a business' break room, the Forest Hill High School junior began contemplating potential careers that would allow him to capitalize on his artistic gifts.</p>

<p id="h183403-p68" class="permalinkable">Initially, he pondered video-game design but reconsidered after learning more about the prerequisites for the field and deciding the path was not for him. Nevertheless, the possibility of seeing his creations displayed businesses' advertisements excites him. He considers Eastern media, particularly Nintendo, as inspiration for his artworks, including indie comics and animated television series.</p>

<p id="h183403-p69" class="permalinkable">"I continue to want to get better as an artist and for people to identify me," he says. He would like to expand his artistic repertoire so that he can also draw animals and landscapes.</p>

<p id="h183403-p70" class="permalinkable">When Forest Hill High School began teaching students through virtual means due to the pandemic, Gipson learned that he valued the human connection that comes with physical attendance at school. "I thought I liked to be alone but I also crave the human connection," he says.</p>

<p id="h183403-p71" class="permalinkable">The high-school junior stays busy in a variety of ways. For one, he is involved in musical theater, fostered by a love for Disney songs. In addition, he serves as a band manager for the school band—keeping music files, taking instrument inventory, cleaning the band hall, attending sporting events and preparing food before games. He also utilizes his managerial and leadership skills on the soccer team, building his interest in the sport, as well as in the classroom during group activities and with the honor society of which he is a member. —Mike McDonald</p>

<p id="h183403-p72" class="permalinkable"><strong>Amiracle Johnson</strong></p>




<div class="inline inline_photo inline-right  ">
  <p class="thumbnail">
    <a href="/photos/2021/may/05/38848/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Amiracle-Johnson_courtesy_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Photo courtesy Amiracle Johnson</p>
    
  </div>
</div>


<p id="h183403-p73" class="permalinkable">Amiracle Johnson's exposure to the sciences began in the JROTC program at Lanier High School. The subject appealed to her because she knew she could be a trailblazer in a male-dominated field. More specifically, she has considered career opportunities where a scientific mind could be put to greater utility. Factoring in a mom with high blood pressure and the public-health needs in the community, she landed on nursing.</p>

<p id="h183403-p74" class="permalinkable">Born and raised in Jackson and the youngest of five siblings, Johnson plans to be the first among them to serve in the military while also aspiring to attend a post-secondary institution to later enter the medical field. "I hope to build on the legacy of the veterans," Johnson remarks when explaining her desire to enlist in the first place. While part of the program, she strives to be a role model for her cousins, nieces and nephews—demonstrating that they can "do better" if they seek it, she says.</p>

<p id="h183403-p75" class="permalinkable">In addition to military-preparedness training, the JROTC program also introduced her to new people and ideas. "My oldest sister was a (JROTC) member, and I asked her about it," she says. "At school I met people from all over who created an open-mindedness in me. It's also helped me work on my attitude."</p>

<p id="h183403-p76" class="permalinkable">Johnson displays her leadership skills through class debates, participation on the drill team and as a student representative for the school who meets with the Jackson Public Schools administration to discuss certain topics. Looking forward, she hopes to see contention between peoples across the country improve. —Mike McDonald</p>

<p id="h183403-p77" class="permalinkable"><strong>Xenia Minton</strong></p>




<div class="inline inline_photo inline-right  ">
  <p class="thumbnail">
    <a href="/photos/2021/may/05/38849/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Xenia-Minton_cred-Destiny-Perkins_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Photo courtesy Destiny Perkins</p>
    
  </div>
</div>


<p id="h183403-p78" class="permalinkable">Xenia Minton's senior year is almost finished, but she has been helping other seniors commemorate their final high-school milestones since she was a freshman, transforming her love for photography into a business that specializes in senior portraits. "More and more people heard about it," Minton recalls. "So it took off from there. I've done 25 or 30 sessions this year."</p>

<p id="h183403-p79" class="permalinkable">When she's not behind the camera, the St. Andrew's Episcopal School senior stays active on the cross-country team, serving as the team's captain for the duration of her senior season. "It was a lot to balance with my photography business, but I like staying busy," Minton says.</p>

<p id="h183403-p80" class="permalinkable">Despite her commitment to her extracurricular activities, Minton admits that her class schedule alone would have been enough to keep her occupied, as she's presently enrolled in AP Literature, Government and Chinese, the latter of which is near to her heart.</p>

<p id="h183403-p81" class="permalinkable">Minton, who was adopted from China as a baby, believes that her study of the language—which included a school-service trip a few years back—has helped her form an important connection to her heritage. "I'm Chinese-American, but I don't have Chinese family, so it was really cool to connect to my heritage in that way and be surrounded with people who look like me," she says.</p>

<p id="h183403-p82" class="permalinkable">The senior expected to do additional travelling once she completed her high-school career, remarking that she "never imagined that she would be staying in-state to go to college." A visit to the University of Mississippi, though, changed that vision, and Minton plans to move there this fall to major in integrated marketing and communications. "I don't think I saw it at first, but I truly do love Mississippi," Minton concludes. —Taylor McKay Hathorn</p>

<p id="h183403-p83" class="permalinkable"><strong>Cameron Lewis</strong></p>




<div class="inline inline_photo inline-right  ">
  <p class="thumbnail">
    <a href="/photos/2021/may/05/38850/">
      
        
          
            <img class="photo" src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2021/05/05/Cameron-Lewis_courtesy_web_t180.jpg?370a03faaa4bde2115f371a02430eb3e6a451be5" alt="photo">
          
        
      
    </a>
  </p>

  <div class="photo_meta">
    

    

    
      <p class="caption">Photo courtesy Cameron Lewis</p>
    
  </div>
</div>


<p id="h183403-p84" class="permalinkable">Cameron Lewis has spent much of the past year advocating for his fellow students as a member of a unique group: the State Superintendent of Education Carey Wright's advisory board. "There's a bunch of kids from a lot of different schools (on the board)," Lewis says. "We talk about things we think the state school board could do better and what they could implement to make things better for us and the upcoming generations."</p>

<p id="h183403-p85" class="permalinkable">The high-school junior acknowledges that he's been "blessed and privileged" during his time as a student at Clinton High School, and he hopes that his time on the board will help grant other students those same opportunities. Two such instances of good fortune are Lewis's position as an outside back on the Arrow soccer team and his involvement in the Attache show choir, which is currently ranked number one in the nation. "Getting to be involved (in those activities) is something I cherish, and it's something that's shaped me as a high-school student," Lewis reflects.</p>

<p id="h183403-p86" class="permalinkable">He hopes to foster that love of music in college, though he says he also wants to study broadcast journalism. "I love watching the news," Lewis remarks, citing CNN as his favorite television news outlet. "So I would want to be a political analyst. I think—and this probably goes not just for analysts but for all media—we're the regular person's information. We play an important role in educating people and keeping them informed, whether the news is good or bad." —Taylor McKay Hathorn</p>

  
    
  </div>

  
  
  

  






     
      

<div class="pgs-dpg-flex"></div>

        <!-- Go to www.addthis.com/dashboard to customize your tools --> <div class="addthis_inline_share_toolbox" style="margin-top:5px" align="center"></div>
      
    


  
  
  

  
  <div class="recommended">
    <h3>More stories by this author</h3>
    <ul>
      
      
        <li><a href="/news/2021/may/05/best-jackson-healthcare-2021/">Best of Jackson: Healthcare 2021</a></li>
      
        <li><a href="/news/2021/feb/04/best-jackson-2021/">Best of Jackson 2021</a></li>
      
        <li><a href="/news/2021/feb/03/best-jackson-2021-food/">Best of Jackson 2021: Food and Drink</a></li>
      
        <li><a href="/news/2021/feb/03/best-jackson-2021-urban-living/">Best of Jackson 2021: Urban Living</a></li>
      
        <li><a href="/news/2021/feb/03/best-jackson-2021-nightlife-and-music/">Best of Jackson 2021: Nightlife and Music</a></li>
      
    </ul>
  </div>
  

<!-- div align="center" style="border:1px dotted;padding: 5px;margin-bottom:10px;">
<a href="https://form.jotform.com/jacksonfreepress/vipannual"><img src="https://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2020/04/23/Uplift_JFP6_t670.jpg" width="100%" /></a>
<h3>Thanks to all our new JFP VIPs!</h3>
<p style="font-family: Arial; Helvetica;"><strong>COVID-19 has closed down the main sources of the JFP's revenue -- concerts, festivals, fundraisers, restaurants and bars. <a href="https://form.jotform.com/jacksonfreepress/vipannual">If everyone reading this article gives $5 or more, we should be able to continue publishing through the crisis.</a> Please <a href="https://form.jotform.com/jacksonfreepress/vipannual">pay what you can</a> to keep us reporting and publishing.</strong></p>
</div -->

  <div class="recommended">
<div class='mailmunch-forms-widget-387064'></div>
  </div>

  

  
    

<div id="comments"> 

  
  
    
    
    
      
      

<h3 class="header">Comments</h3>

  <p class="no_comments">Use the comment form below to begin a discussion about this content.</p>

      
    
  

  
  

    <div id="disqus_thread"></div>
    <script type="text/javascript">
        /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
        var disqus_shortname = 'jacksonfreepress'; // required: replace example with your forum shortname

        /* * * DON'T EDIT BELOW THIS LINE * * */
        (function() {
            var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
            dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
            (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
        })();
    </script>
    <noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
    <a href="https://disqus.com" class="dsq-brlink">comments powered by <span class="logo-disqus">Disqus</span></a>

    <script type="text/javascript">
    /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
    var disqus_shortname = 'jacksonfreepress'; // required: replace example with your forum shortname

    /* * * DON'T EDIT BELOW THIS LINE * * */
    (function () {
        var s = document.createElement('script'); s.async = true;
        s.type = 'text/javascript';
        s.src = '//' + disqus_shortname + '.disqus.com/count.js';
        (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
    }());
    </script>
    </div>
  


            



          </div>
        

        
          <div class="sidebar">
            


            
    

    

<div>

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));
</script>

<div style="clear:both;" class="fb-like-box" data-href="http://www.facebook.com/jacksonfreepress" data-width="300" data-show-faces="true" data-border-color="#fff" data-stream="false" data-header="false"></div>

<h3>COVID-19 Coverage</h3>

<p><a href="http://jacksonfreepress.com/coronavirus/"><img src="https://jacksonfreepress.media.clients.ellingtoncms.com//img/photos/2020/03/19/COVID_Banner.jpg" width="300px" /></a><br />See our archive of <a href="http://jacksonfreepress.com/coronavirus/">continuing coverage of COVID-19</a> in Jackson and Central Mississippi. We're actively updating these threads: <a href="https://www.jacksonfreepress.com/news/2020/mar/12/event-cancelations-due-covid-19/">Event Cancellations</a> and <a href="https://www.jacksonfreepress.com/news/2020/mar/18/jackson-restaurants-offering-curbside-service/">Curbside Restaurant Service</a>.</p>

</div>


<!-- div class="section home-best-bets" style="width: 300px!important"> 
<div data-cswidget="8346" width="300px" > </div>
<script type="text/javascript" async defer src="//portal.CitySpark.com/js/widget.min.js" > </script>
</div>
<div -->

<!-- div>
<h3>Special Section</h3>
<p>
<a href="https://www.dropbox.com/s/yj68w4ydejo54rx/Camp_Guide_2017.pdf?dl=0"><img src="http://jacksonfreepress.media.clients.ellingtoncms.com/img/photos/2017/04/04/Camp_Cover_2017_t670.jpg" /></a>
</p>
</div -->

    

<h3>Sponsors</h3>
 
<!-- /1024782/Top_300_250 -->
<div class="ad">
<div id='div-gpt-ad-1550259823887-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1550259823887-0'); });
</script>
</div>
</div>

<div>

    <!--  TWITTER
    =========================================================================================== -->
    <div class="twitter_module">
        <h3>JFP Tweets</h3>
        <div id="twitter"></div>

<a class="twitter-timeline" href="https://twitter.com/JxnFreePress" data-widget-id="347027636788269058">Tweets by @JxnFreePress</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
</div>

<div class="ad">
<h3>Sponsors</h3>
<!-- /1024782/Top_Skyscraper -->
<div style="text-align:center;" id='div-gpt-ad-1550262894638-0' style='height:600px; width:160px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1550262894638-0'); });
</script>
</div>
</div>

<div class="ad" style="background: #eeeeee; padding:5px; border-bottom:1px;">
<h3>Top Stories</h3>
<script id="fdncms-carousel-top-stories-video" src="https://www.hub.fdncms.com/gyrobase/Responsive/Components/Content/TopStoriesVideo?cb=0bc72b9c&key=5f6f55ebf4de1c82b8ef50232c4ffa3f&req=js" async></script>
<hr />
</div>

<div>
<h3>Sponsors</h3>
<!-- /1024782/Second_Skyscraper -->
<div style="text-align:center;" id='div-gpt-ad-1550263161137-0' style='height:600px; width:160px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1550263161137-0'); });
</script>
</div>
</div>


<div id="RecentComments" class="dsq-widget">
 <h3>Recent Comments</h3>
 <script type="text/javascript" src="https://jacksonfreepress.disqus.com/recent_comments_widget.js?num_items=5&hide_mods=0&hide_avatars=1&avatar_size=0&excerpt_length=80"></script>
<p><a href="https://www.jacksonfreepress.com/comments/disqus">see recent 25 &raquo;</a></p>
</div>

<div class="ad">
<!-- /1024782/Second_300_250 -->
<div id='div-gpt-ad-1550263248411-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1550263248411-0'); });
</script>
</div>
</div>


          </div>
        
      
    </div>
  </div>
  

  
  <div id="footer">
    <div class="wrapper">
      
        

        <dl>
          <dt>Sections</dt>
          <dd>
            <a href="/news/all/">News</a>,
            <a href="/news/opinion/">Opinion</a>,
            <a href="/news/arts/">Arts</a>,
            <a href="/news/music/">Music</a>,
            <a href="/news/music/">Events</a>,
            <a href="/news/lifestyle/">Life+Style</a>,
            <a href="/news/food&drink/">Food+Drink</a>,
            <a href="/news/sports/">Sports</a>
          </dd>
          <dt>Events</dt>
          <dd>
            <a href="/events/">Events Calendar</a>,
            <a href="https://portal.cityspark.com/Account/PopLogin?ReturnUrl=%2fEventEntry%2fEventEntry%2fJacksonFreePress">Submit an Event</a>
          </dd>
          <dt>Media</dt>
          <dd>
            <a href="/photos/">Photos</a>,
            <a href="/photos/galleries/">Galleries</a>,
            <a href="/videos/">Videos</a>,
            <a href="/audioclips/">Audio</a>,
            <a href="/documents/">Documents</a>
          </dd>
          <dt>Advertise</dt>
          <dd>
            <a href="/advertise/">In the JFP</a>,
            <a href="http://www.jfpclassifieds.com/">Classifieds</a>,
            <a href="/cdn-cgi/l/email-protection#b9cdd6ddddf9d3d8dad2cad6d7dfcbdcdcc9cbdccaca97dad6d4">Email the Publisher</a>
          </dd>
          <dt>About</dt>
          <dd>
            <a href="https://www.jacksonfreepress.com/masthead/">Meet Our Staff</a>, <a href="https://www.jacksonfreepress.com/jobs/">Apply for a Job</a>
          </dd>
        </dl>
        <p >
        &copy; Jackson Free Press, Inc.<br/>
        <a href="/user-agreement/">User agreement and privacy statement.</a><br/>
        phone: 601-362-6121 (ext 11 sales, ext 16 editorial, ext 17 publisher)<br/>
        fax: 601-510-9019<br/>
        125 S. Congress St. #1324 * Jackson, MS * 39201
        </p>

<!-- Analytics -->

        <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">

              var _gaq = _gaq || [];
              _gaq.push(['_setAccount', 'UA-792151-1']);
              _gaq.push(['_setDomainName', 'jacksonfreepress.com']);
              _gaq.push(['_trackPageview']);

              (function() {
                var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
              })();

              /*
                Meebo("domReady");
                */

        </script>

      
    </div>
  </div>
  

</div>


<!-- GetSiteControl Script -->
<script>
  (function (w,i,d,g,e,t,s) {w[d] = w[d]||[];t= i.createElement(g);
    t.async=1;t.src=e;s=i.getElementsByTagName(g)[0];s.parentNode.insertBefore(t, s);
  })(window, document, '_gscq','script','//widgets.getsitecontrol.com/165599/script.js');
</script>


<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-58KldfcjIY_EY"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-58KldfcjIY_EY.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->

<script type="text/javascript" class="teads" async="true" src="//a.teads.tv/page/70244/tag"></script>

<!-- Go to www.addthis.com/dashboard to customize your tools --> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=jacksonfreepress"></script> 

<script type="text/javascript" src="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/javascript/lib/cookies.js"></script>

  <script type="text/javascript" src="https://jacksonfreepress.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/javascript/lib/mobile_detect.js"></script>

  <script>

     var cookie_value = Ellington.Cookies.get_cookie('template_preference');

     var domain  = "http://www.jacksonfreepress.com";

        if (cookie_value === null) {

          if (Ellington.TabletDetect()) {

            Ellington.Cookies.set_cookie('template_preference', 'mobile');

               window.location.href = domain.replace('www', 'm') + window.location.pathname;

          }

          if (Ellington.MobileDetect()) {

            Ellington.Cookies.set_cookie('template_preference', 'mobile');

               window.location.href = domain.replace('www', 'm') + window.location.pathname;


          }

        } else if (cookie_value == 'mobile' || cookie_value == 'tablet') {

               window.location.href = domain.replace('www', 'm') + window.location.pathname;


        }

  </script>

<script src="https://my.hellobar.com/1b1209fae4614f70b9e839d5864cadd2c8ffae91.js" type="text/javascript" charset="utf-8" async="async"></script>

</body>
</html>
